1043 输出PATest - PAT乙级

1043 输出PATest(20 point(s))

给定一个长度不超过 10^4的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest…. 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过 10^4​的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee

Solution:

Hash散列将字符key转化成对应索引, 每出现一次cnt+1, 让散列表中的字符按照顺序循环打印, 每次打印都减少次数, 直到次数为空

#include <iostream>
#include <string>
#include <cstring>
using namespace std;

char chars[6] = {'P', 'A', 'T', 'e', 's', 't'};

int main() {
int cnt[6];
memset(cnt, 0, sizeof(cnt));
string s; cin >> s;
for (int i = 0; i < s.length(); i++) {
for (int j = 0; j < 6; j++)
if (s[i] == chars[j]) { cnt[j]++; break; }
/*
if (s[i] == 'P') cnt[0]++;
else if (s[i] == 'A') cnt[1]++;
else if (s[i] == 'T') cnt[2]++;
else if (s[i] == 'e') cnt[3]++;
else if (s[i] == 's') cnt[4]++;
else if (s[i] == 't') cnt[5]++;
*/
}

int ok;
do {
ok = 0;
for (int i = 0; i < 6; i++) {
if (cnt[i]) {
ok = 1;
printf("%c", chars[i]);
cnt[i]--;
}
}
} while (ok);

return 0;
}