1028 List Sorting (25) - PAT甲级

1028 List Sorting (25)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

Solution:

使用c++的string比较case6超时, string替换成字符数组, vector替换成Node数组. 用strcmp比较。

#include <string.h>
strcmp(str1, str2); // str1字典序比str2小, 返回负值, 具体看差值; 相等为0

在之前vector版本中, 重新使用了一个Node{id, name, score}的构造技巧

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct Node {
char id[10];
char name[10];
int score;
};

bool cmp1(Node n1, Node n2) {
return strcmp(n1.id, n2.id) < 0;
}

bool cmp2(Node n1, Node n2) {
if (strcmp(n1.name, n2.name) != 0) return strcmp(n1.name, n2.name) <= 0;
return strcmp(n1.id, n2.id) < 0;
}

bool cmp3(Node n1, Node n2) {
if (n1.score != n2.score) return n1.score <= n2.score;
return strcmp(n1.id, n2.id) < 0;
}

Node nodes[100050];

int main() {
int N, C; scanf("%d %d", &N, &C);
int n = 0;
while (N--) {
scanf("%s %s %d", nodes[n].id, nodes[n].name, &nodes[n].score);
n++;
}
switch (C) {
case 1: sort(nodes, nodes + n, cmp1); break;
case 2: sort(nodes, nodes + n, cmp2); break;
case 3: sort(nodes, nodes + n, cmp3); break;
}
for (int i = 0; i < n; i++) {
printf("%s %s %d\n", nodes[i].id, nodes[i].name, nodes[i].score);
}
return 0;
}