1011 World Cup Betting(20) - PAT甲级

1011 World Cup Betting(20)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

 W    T    L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

Solution:

比较得到三个double中最大的那个值的序号, 0,1,2对应W, T, L;
对赔率进行累乘, 最后(sum*0.65-1)*2是所要的结果, 注意精确到小数点后两位

// 比较三个值的one line写法
int max = a > b ? a > c ? a : c : b > c ? b : c;

#include <cstdio>

char chs[3] = {'W', 'T', 'L'};
int main() {
int flag = 0;
double sum = 1;
for (int i = 0; i < 3; i++) {
double arr[3];
scanf("%lf %lf %lf", &arr[0], &arr[1], &arr[2]);

int pos = arr[0] > arr[1] ? arr[0] > arr[2] ? 0 : 2 : arr[1] > arr[2] ? 1 : 2;
if (flag) printf(" ");
printf("%c", chs[pos]);
flag = 1;

sum *= arr[pos];
}
sum = (sum * 0.65 - 1) * 2;
printf(" %.2lf", sum);
return 0;
}